Uploaded image for project: 'IGB'
  1. IGB
  2. IGBF-2170

Installed button color is not changed when the app is upgraded

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Description

      When a higher version of the app is available on the IGB Appstore, if we navigate to the app page and click on the upgrade button then the button text is changed to installed but the color remains the same.
      I don't know if this is happening for a random case. Could you please look into it?
      Attaching a screenshot FYR.

        Issue Links

          Activity

          rpatil14 Riddhi Jagdish Patil added a comment -

          Issue:
          Installed button color is not changed when the app is upgraded

          Files changed:
          static/apps/js/app_page.js
          https://bitbucket.org/rpatil14/appstore_riddhi/branch/IGBF-2170

          Testing steps:
          1) Submit an app and approve it
          2) Once released install the app
          3) Next submit and approve upgraded version of same app
          4) Once the app is released, click upgrade the app to install it.
          Installed button now should appear in green color

          Testing result:
          Code changes deployed to https://dev-appstore-6.bioviz.org. Admin username and password same as DevAppstore2

          cc.Ann Loraine

          aloraine Ann Loraine added a comment - - edited

          I did the above workflow on dev-appstore-6 using App for Testing App Workflow versions 1.0.0 and 2.0.0., which are compatible with IGB 9.1.0. I tested using IGB 9.1.0.

          The above workflow was successful but I needed to refresh both the App Store page and the repository itself within App Manager. Also, before I refreshed the App Store page (between Steps 3 and 4), the button on the App Store page incorrectly showed yellow/orange-colored "Upgrade IGB" message even though I was running the latest and most up-to-date IGB.

          Requesting clarification: Is this the expected behavior?

          rpatil14 Riddhi Jagdish Patil added a comment -

          The "Get latest IGB" button appears because of following code change:
          To display proper button (i.e. Install, Get latest IGB or Upgrade the App) on the screen, we compare the app version from the IGB App Manager with the Latest released app version from the AppStore.
          We made following assumption while displaying proper button:
          If the App displayed in IGB App Manager is of lower version than what is released in AppStore then we assume that the new released app is not supported by the IGB version installed.

          Thus, unless we refresh the IGB App Manager to fetch the new released app and show upgrade button if the app is compatible to local IGB, the AppStore will display "Get latest IGB" button. This is a known issue and solution to it is to refresh the Repository of IGB App Manager.

          aloraine Ann Loraine added a comment -

          Thank you for the detailed explanation.
          Please submit PR at your earliest convenience.

          cc: Riddhi Jagdish Patil

          aloraine Ann Loraine added a comment -

          Merged.

          prutha Prutha Kulkarni added a comment -

          Tested the fix on dev-appstore-2. Its working fine. There is one known issue which is when we click on upgrade, the app store shows upgrading but the text doesn't change to Installed. If you refresh the page then "Installed" text on the button will be shown. This is fixed by sameer. For now moving the ticket to done as the fix will not be merged for the upcoming release.


            People

            • Assignee:
              rpatil14 Riddhi Jagdish Patil
              Reporter:
              prutha Prutha Kulkarni
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development

                  Agile