Uploaded image for project: 'IGB'
  1. IGB
  2. IGBF-2017

Installation of apps from AppStore and IGB App Manager Tool failing

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:

      Description

      The installation of Apps from Appstore and from IGB App Manager GUI is failing. Steps to reproduce the defect:
      1) Click on the first app available on the AppStore
      2) The blue "Install" button will be visible.
      3) Clicked "Install"
      4) Button changed to "Installing..." and also changed color (lighter shade of blue) but did not change after that
      5) Open IGB App Manager GUI and note that the App failed to install

        Activity

        rpatil14 Riddhi Jagdish Patil added a comment - - edited

        Issue:
        Installation of apps failing from AppStore and IGB App Manager Tool

        Solution:
        The uri of the media path in repository.xml for the first app pending / submitted was malformed. Due to this the media path was not available for the AppStore to install the app.
        For eg. the old uri created in repository.xml was uri="super-simple-igb-app-0.0.3.jar" only which was just the jar name without file path.
        With this code changes new uri created will have the folder structure path to the jar.For eg. /media/super-simple-igb-app/releases/0.0.3/super-simple-igb-app-0.0.3.jar
        Fixed repository.xml uri for both pending and submitted apps.

        Files changed:
        obr/repogen.py
        https://bitbucket.org/rpatil14/appstore_riddhi/branch/IGBF-2017#diff

        Testing steps:
        Use test environment for this feature - https://dev-appstore-6.bioviz.org/
        1) Start IGB on local machine
        2) Click Tools -> Open App Manager -> Manage Repositories -> Add URL https://dev-appstore-6.bioviz.org/obr/releases
        3) Click Install button on any app from the App Store and check IGB App Manager Tool to see if the app is installed
        or
        4) Click on Install button on any App from IGB App Manager Tool to see if the app is installed

        Check uri formation in repository.xml :
        https://dev-appstore-6.bioviz.org/obr/releases/repository.xml

        Ann Loraine

        aloraine Ann Loraine added a comment -

        Please also check that the pending apps repository is also working properly. For testing purposes (before approving apps) we need to be able to install apps.

        rpatil14 Riddhi Jagdish Patil added a comment -

        Tested pending apps as well. The uri formed for the pending apps is as expected.
        https://dev-appstore-6.bioviz.org/obr/pending_releases/repository.xml

        aloraine Ann Loraine added a comment -

        Thanks! Riddhi Jagdish Patil please proceed with PR.

        aloraine Ann Loraine added a comment -

        Merged, not yet deployed on EC2.

        aloraine Ann Loraine added a comment -

        Deployed on dev-appstore-2.bioviz.org. Shamika Gajanan Kulkarni or Noor Zahara please test.

        sameer Sameer Shanbhag added a comment -

        Working as Expected. I can install app from the Dev-appstore-1 instance.
        Attached a screenshot.

        Moving this thread to Done.


          People

          • Assignee:
            rpatil14 Riddhi Jagdish Patil
            Reporter:
            rpatil14 Riddhi Jagdish Patil
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development

                Agile